Re: substr/array_slice in []

From: Date: Sat, 06 Oct 2007 19:57:18 +0000
Subject: Re: substr/array_slice in []
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-32682@lists.php.net to get a copy of this message
I hardly find it too cryptic (it makes some array algorythms much more readable, actually) and in this case, having such construction would allow us to implement array_slice() in userland (which is not true other way round) ;) On 10/6/07, Antony Dovgal <tony@daylessday.org> wrote: > On 06.10.2007 22:38, Larry Garfield wrote: > > I have no love for Perl (and a rather strong dislike of it), but I have to > > agree with those who say that "looks like Perl" is a lame reason to reject > > something. PHP's object system looks an awful lot like Java, too. That > > doesn't make it bad. > > > > "Too unreadable", "not approachable enough", "too > > inflexible", etc. are > > perfectly valid reasons to reject a syntax. "Looks like <insert language > > here>" is not, I content, one of them. > > I believe it should be pretty clear that "too perlish" means "too cryptic > and makes no sense because it duplicates already implemented functionality > (more than one way to do it, yeah)". > > But "too perlish" is much shorter. > > -- > Wbr, > Antony Dovgal > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php > > -- Alexey Zakhlestin http://blog.milkfarmsoft.com/

« previous php.internals (#32682) next »