Re: [RFC] prepend_include_path()/append_include_path()

From: Date: Thu, 14 Feb 2008 09:07:56 +0000
Subject: Re: [RFC] prepend_include_path()/append_include_path()
References: 1 2 3 4  Groups: php.internals 
Request: Send a blank email to internals+get-35483@lists.php.net to get a copy of this message
Hi Jochem, Am Donnerstag, den 14.02.2008, 00:56 +0100 schrieb Jochem Maas: > I think Lars has a point ... maybe set_include_path() could > be given a second parameter instead to mitigate the need for seperate > funcs?: > > set_include_path('foo', INCPATH_OVERRIDE); // default > set_include_path('foo', INCPATH_APPEND); > set_include_path('foo', INCPATH_PREPEND); Thanks for your support, but this seems counter intuitive. Why should *set*_include_path() be used to *append* or *prepend* to the include path? Also learning another mouthful of constants is maybe suboptimal. Getting used to prepend_/append_...() is easy from my point of view, as the name is derived from what's currently present (set_include_path()). cu, Lars

« previous php.internals (#35483) next »