Re: practical phar considerations

From: Date: Wed, 09 Apr 2008 06:57:50 +0000
Subject: Re: practical phar considerations
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-36893@lists.php.net to get a copy of this message
Hi, On Wed, Apr 9, 2008 at 6:48 AM, Gregory Beaver <greg@chiaraquartet.net> wrote: > For other examples, take a look at at > ext/zip. There is no support for opendir() in the stream wrapper of > ext/zip because it requires the kind of path grepping that pecl/phar > does. That's easy to add and will be available at some point, that was simply not needed and nobody ever requested this feature. Extract or add using a pattern is however much more useful. It is already partially supported. > > Yes, this shouldn't be allowed while > > $phar['foo/bar/baz'] = new DirectoryIterator(); could be allowed. > > I will simply add makeEmptyDir() a la zip, although it is too bad > ext/zip never thought to go with mkdir(). I thought about mkdir but it is a bad name as it implies a shell command. makeEmptyDir while being longer is self explaining. I also asked before choosing this name, as far as I remember nobody proposed mkdir either. Cheers, -- Pierre http://blog.thepimp.net | http://www.libgd.org

« previous php.internals (#36893) next »