RE:Re[2]: [PHP-DEV] Re: hook cast_object handler in userspace
| From: | Simeon Koptelov | Date: | Mon, 04 Aug 2003 12:33:00 +0000 |
| Subject: | RE:Re[2]: [PHP-DEV] Re: hook cast_object handler in userspace | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-3716@lists.php.net to get a copy of this message | ||
Hello Cristiano,
Monday, August 4, 2003, 8:45:20 AM, you wrote:
>> CD> Should the method be named "to_string()", "tostring()" or
CD> "__tostring()" ?
Maybe the __tostring() will be the best because few naming
conventions for methods exist. Some people prefer C-like some_method(), some
like Java-like someMethod() etc. But there is already in PHP5
pre-defined methods like __clone, __construct, __destruct so the
"__tostring" name will be expected by user. The "__to_string" will
also be though. I have seen no "__" methods with names having two
words so this variants are equal from my point of view.
CD> I modified the code to just call to_string if the object implements the
CD> "printable" interface.
The printable is IMHO definetly not good name for such interface. When
user sees the "implements Printable" he expects methods like
print(), println() etc. that do something, not return strings.
I can't name this interface better though.
Maybe it will be better to have this method in all classes and define
default behavior such as existing ( string )$object cast?
--
Best regards,
Simeon mailto:xi@newmail.ru