Re: [RFC] Iteration tools

From: Date: Tue, 04 Nov 2008 09:39:51 +0000
Subject: Re: [RFC] Iteration tools
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-41634@lists.php.net to get a copy of this message
On Tue, Nov 4, 2008 at 10:11 AM, Ionut Gabriel Stan <ionut.g.stan@gmail.com> wrote: > Anyway, I see there's nobody else that would like this but it's ok, at least > now we have namespaces so that > I don't have to come up with ugly names like my_map() for these kind of > helper functions. I like the proposal. With the advent of first-class functions, functional-style iteration is becoming possible. An abstraction that hides away the difference between arrays and traversables would help further in this direction. And this is something that is much better implemented in the language, than in userland, to ensure interoperability. -- troels

« previous php.internals (#41634) next »