Throwing E_DEPRECATED on startup

From: Date: Fri, 06 Feb 2009 19:06:23 +0000
Subject: Throwing E_DEPRECATED on startup
Groups: php.internals 
Request: Send a blank email to internals+get-42962@lists.php.net to get a copy of this message
G'day I'd like to propose a change for when PHP starts to throw an E_DEPRECATED notice for each of the deprecated ini directives (such as register_globals, safe_mode ect.) like in HEAD where they just throw a warning (more about that below). I have attached a patch for this in 5.3 (which is the only branch this patch really relates to). As you can see in the patch, I've also changed the zend.ze1_compatibility_mode to throw an fatal error instead of a previously warning which forces people to update their php.ini or refactor their script to use newer and better behavior. Speaking of changing to a fatal error, I would also like to propose to do the same in HEAD (which I've also attached a patch to). I'd like to include this in the next 5.3 release, whether its Beta 2 or RC1, feedback are welcome! -- Kalle Sommer Nielsen

« previous php.internals (#42962) next »