Re: ini value of On = 1 and Off = "" ? (Re: [PHP-DEV] RFC for new INI's)
| From: | Christopher Jones | Date: | Tue, 10 Feb 2009 19:09:04 +0000 |
| Subject: | Re: ini value of On = 1 and Off = "" ? (Re: [PHP-DEV] RFC for new INI's) | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-42989@lists.php.net to get a copy of this message | ||
Markus Fischer wrote:
Sorry to hijack, but ... Christopher Jones wrote:It improves human readability of php.ini, making it clear that the parameter value range is not numeric.oci8.events and oci8.old_oci_close_semantics are boolean, so we can take this opportunity to change the 1 and 0 to On and Off.... I've never understood why writing On/Off is a good idea,
when it is not intuitive that the value returned from ini_get() is of a different content (not meaning, however).It could possibly be argued there is an inconsistency somewhere, but then PHP type juggling and comparison have their own "charm". Chris -- Email: christopher.jones@oracle.com Tel: +1 650 506 8630 Twitter: http://twitter.com/ghrd Free PHP Book: http://tinyurl.com/UGPOM