Re: Proposed Function: urlencode_array
| From: | Sara Golemon | Date: | Tue, 02 Sep 2003 21:22:51 +0000 |
| Subject: | Re: Proposed Function: urlencode_array | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-4360@lists.php.net to get a copy of this message | ||
Since Wez has been talking about an http_request() function (which inspired
the underlying php_url_encode_hash() function), using a name like
http_query_string() (or similar) might suffice for both naming conventions
and suitability.
-Sara
> I find this useful, but the name is a bit confusing because the function
> works differently than a combo of urlencode() / rawurlencode() and
> array_map(). One of my picks is build_query_string() (this doesn't conform
> to the naming convention though.)
>
> > proto urlencode_array(array formdata [, string numeric_prefix])
> >