RE: [PHP-DEV] differences in the RDBMS ext API's

From: Date: Thu, 25 Sep 2003 07:22:32 +0000
Subject: RE: [PHP-DEV] differences in the RDBMS ext API's
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-4575@lists.php.net to get a copy of this message
> From: Dan Kalowsky [mailto:dank@deadmime.org] > Sent: Wednesday, September 24, 2003 8:00 PM > I don't have the time to answer this in more detail, but some of these > calls are just not supported by ODBC (i.e. select_db). Some are, I just > haven't had the time to commit the patches that create the functionality > and fully test it. Yeah. I am not trying to slap wrist here :-) And yes obviously some functions simply don't apply to certain extensions. But I am hoping that maybe we can come up with a unified naming scheme and one by one move the existing extensions over. Finally the names I choose to use in the list ar not my personal recommendations. For example xxx_free_query is not a good name for a function that frees a prepared query. Also I never liked using "field" instead of "column". I was just trying to start a discussion. Regards, Lukas

« previous php.internals (#4575) next »