Re: syntax of configuration file

From: Date: Wed, 09 Dec 2009 19:52:52 +0000
Subject: Re: syntax of configuration file
References: 1 2 3 4 5 6 7 8 9  Groups: php.internals 
Request: Send a blank email to internals+get-46377@lists.php.net to get a copy of this message
Le 9 décembre 2009 20:44, Michael Shadle <mike503@gmail.com> a écrit : > I see it more like: > > fpm.global.daemonize = yes > fpm.global.error_log = /var/log/php-fpm.log > > or skip global: > > fpm.daemonize = yes > fpm.error_log = /var/log/php-fpm.log > > > for each worker pool: > > fpm.worker1.name = pool1 > fpm.worker1.address = 127.0.0.1:9000 ; or socket > fpm.worker1.uid = www-data > fpm.worker1.gid = www-data > > OR array style... > > fpm.worker('pool1').name = pool1 > fpm.worker('pool1').address = 127.0.0.1:9000 ; or socket > fpm.worker('pool1').uid = www-data > fpm.worker('pool1').gid = www-data > > for nested options can't it be > > fpm.worker1.foo.bar.baz = value > > (or the alternative array style for worker1) using array like described will made conf file unreadable and very hard to read and write (repeated words ...) > > These would all need to be PHP_INI_SYSTEM or the max level they can > be. I don't think it makes sense to be able to modify any of them. > do you mean that it would be included in the global php.ini file ? I never imagine that. For me it's an independant conf file (/etc/php-fpm.conf for example).

« previous php.internals (#46377) next »