Re: Expose compare_function() to userspace
| From: | Stas Malyshev | Date: | Thu, 30 Sep 2010 20:13:49 +0000 |
| Subject: | Re: Expose compare_function() to userspace | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-49828@lists.php.net to get a copy of this message | ||
Hi!
If I don't hear kicking and screaming in the next few days, I'll slip this into trunk. I can provide a patch/RFC in advance if there's demand, but it'll be about as simple as you imagine. :)Sounds good.
The one thing that I would like bikeshedding^Wfeedback on is the name: cmp() makes the most sense to me, since it lines up well with Python and (to a lesser extent) Perl, but if there are concerns about potential name clashes with existing code, may I suggest var_compare(). Get your votes and/or suggestions in!I'd like var_compare(). Quick search in google reveals cmp() being used in actual code, and compare() to some extent too, though mostly as method, so not really clashing. -- Stanislav Malyshev, Software Architect SugarCRM: http://www.sugarcrm.com/ (408)454-6900 ext. 227