Re: [PATCH] SplObjectStorage::removeCommon and removeUncommon
| From: | Matthew Turland | Date: | Mon, 20 Dec 2010 19:41:29 +0000 |
| Subject: | Re: [PATCH] SplObjectStorage::removeCommon and removeUncommon | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-51097@lists.php.net to get a copy of this message | ||
Thanks to comments from Gustavo Lopes, I've removed the removeCommon
method from my patch. I honestly wish I could say why I didn't realize
his point before I submitted the patch in the first place, but I
appreciate the feedback. I've attached the amended patch files, which
include only the removeUncommon method, which I definitely know does
not already exist in the class.
php-src-5.3-patch.diff is against php/php-src/branches/PHP_5_3
phpdoc-en-trunk-patch.diff is against phpdoc/en/trunk
As for the comments regarding the naming conventions, I do agree to a
certain extent. However, I would like to remain consistent with the
format of names of existing methods. I suggest a separate patch be
submitted with method aliases to deal with that situation. If anyone
has a better name for the removeUncommon method, I'm open to
suggestions.
Any further feedback and/or approval/merging would be appreciated.
Regards,
Matthew Turland
Attachment: [text/x-patch] phpdoc-en-trunk-patch.diff
Attachment: [text/x-patch] php-src-5.3-patch.diff
Attachment: [text/x-patch] phpdoc-en-trunk-patch.diff
Attachment: [text/x-patch] php-src-5.3-patch.diff