Re: SplFileObject Countable

From: Date: Tue, 15 Mar 2011 11:07:01 +0000
Subject: Re: SplFileObject Countable
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-51696@lists.php.net to get a copy of this message
On Tue, Mar 15, 2011 at 1:54 PM, Nick Pope <php@nickpope.me.uk> wrote: > Currently we have: > >    SplFileInfo  -- information/metadata about a file. >         | >         V >   SplFileObject -- modify/access contents of a file. > > It could make sense to subclass this to provide methods for accessing > information about the contents of a file.  As for a name, I'm not sure what > would be best, but perhaps something like "SplFileData".  Maybe someone else > can come up with a better name? probably SplTextFileObject, as these methods make sense for text files -- Alexey Zakhlestin, http://twitter.com/jimi_dini http://www.milkfarmsoft.com/

« previous php.internals (#51696) next »