Re: Adding a more logical string slicing function to PHP
| From: | Reindl Harald | Date: | Wed, 30 Mar 2011 16:00:25 +0000 |
| Subject: | Re: Adding a more logical string slicing function to PHP | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-51754@lists.php.net to get a copy of this message | ||
Am 30.03.2011 17:54, schrieb Chad Fulton:
> While I personally like PHP's substr() an awful lot
>
> With that in mind, if this function was to be implemented, I think
> that naming it substring() instead of str_slice() might make it easier
> for people to pick up out of the box, since PHP developers often have
> quite a bit of overlap with Javascript
a really bad idea!
after that you have substr() and substring() and we should avoid doing
things like "mysql_escape_string" and "mysql_real_escap_string" again
Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc
Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc