Re: Re: [RFC] Improved parser error message
| From: | Gustavo Lopes | Date: | Tue, 17 May 2011 16:07:09 +0000 |
| Subject: | Re: Re: [RFC] Improved parser error message | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-52432@lists.php.net to get a copy of this message | ||
Em Tue, 17 May 2011 17:01:26 +0100, Andi Gutmans <andi@zend.com> escreveu:
Read the archives. We discussed T_PAAMAYIM_NEKUDOTAYIM extensively and agreed to keep it as a historical landmark. Let's not have the discussion yet again within the same year. Google it just to see the # of mentions. What we could do as a compromise between history and improving many of the parse error messages is: Parse error: syntax error, unexpected :: (T_PAAMAYIM_NEKUDOTAYIM) in Command line code on line 1This proposal is not about changing the name of the token, only the message that's shown to the user. The token name will remain as is in zend_language_parser.y et al. If I recall correctly, there was not objection raised to changing the message in the last discussion. Anyway, +1 to the change from you. -- Gustavo Lopes