Re: ReflectionClass::newInstanceWithoutConstructor()

From: Date: Thu, 25 Aug 2011 12:31:07 +0000
Subject: Re: ReflectionClass::newInstanceWithoutConstructor()
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-54931@lists.php.net to get a copy of this message
On 08/25/2011 02:26 PM, Richard Quadling wrote:
Wouldn't ReflectionClass::newMockInstance() be a better name?
It is not specific to stubbing/mocking.
What other use cases exists?
ORM and stubbing/mocking should be enough. -- Sebastian Bergmann Co-Founder and Principal Consultant http://sebastian-bergmann.de/ http://thePHP.cc/

« previous php.internals (#54931) next »