RE: [PHP-DEV] Re: E_STRICT
| From: | Ford, Mike [LSS] | Date: | Wed, 19 Nov 2003 11:07:29 +0000 |
| Subject: | RE: [PHP-DEV] Re: E_STRICT | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-5545@lists.php.net to get a copy of this message | ||
On 19 November 2003 06:12, Andi Gutmans contributed these pearls of wisdom:
> Just a warning.
> I commited your patch. Not sure about the naming but it's the
> status quo for now :)
> Andi
>
>> + case E_STRICT:
>> + error_type_str = "Strict
>> Standards";
>> + break;
As it's a prefix to a more substantive error message, I'd go for something
like "Deprecated Usage" or "No Longer Supported". (The former would also
match up to an (en|dis)able_deprecated option.)
Cheers!
Mike
--
Mike Ford, Electronic Information Services Adviser,
Learning Support Services, Learning & Information Services,
JG125, James Graham Building, Leeds Metropolitan University,
Beckett Park, LEEDS, LS6 3QS, United Kingdom
Email: m.ford@leedsmet.ac.uk
Tel: +44 113 283 2600 extn 4730 Fax: +44 113 283 3211