Re: cvs: php-src / NEWS /ext/standard basic_functions.c head.c head.h
| From: | Sara Golemon | Date: | Thu, 20 Nov 2003 00:17:52 +0000 |
| Subject: | Re: cvs: php-src / NEWS /ext/standard basic_functions.c head.c head.h | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-5597@lists.php.net to get a copy of this message | ||
> As Andi might say: "Why not call this http_headers()?" :)
> (and also rename 'headers_sent' -> http_headers_sent() :)
>
> --Jani
>
As you can probably guess, my answer to your first question is your second
question.
headers_sent() already exists and is in the same general grouping as
header() itself. I'm kosher with naming this new function http_headers()
but only if we rename headers_sent() as http_headers_sent(), but that means
yet another alias for headers_sent() (which goes back to PHP 3.0.8).
Then that still leaves header() by itself (and renaming this one would be a
VERY bad idea IMO).
Thoughts? Votes?