Re: RFC: Property get/set syntax
| From: | Christoph Hochstrasser | Date: | Fri, 20 Apr 2012 07:29:16 +0000 |
| Subject: | Re: RFC: Property get/set syntax | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-60227@lists.php.net to get a copy of this message | ||
Hi,
> Are the dashes acceptable or undesirable?
I think without dashes it is more in line with other keywords, like "instanceof" or
"insteadof".
Because keywords are not case sensitive, one who likes them to be more readable could write them
camelCased, for example "readOnly", or "writeOnly".
--
Christoph Hochstrasser
http://twitter.com/hochchristoph | http://christophh.net | https://github.com/CHH