Re: StudlyCaps
| From: | Pierre-Alain Joye | Date: | Thu, 04 Dec 2003 10:03:57 +0000 |
| Subject: | Re: StudlyCaps | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-6190@lists.php.net to get a copy of this message | ||
On Thu, 4 Dec 2003 10:56:42 +0100 (CET)
Sascha Schumann <sascha@schumann.cx> wrote:
> One of the largest cost in software development is
> maintenance. One key factor regarding maintainability is
> readability and understandability. These issue cannot be
> simply dismissed as irrelevant as you try to make it.
I have to agree. But that does not match the readability argument told
here, as the readability (subjective) enhancement is so small regarding
to the additionnal work due to non studlyCaps internal *methods*.
However I fully agree with you when you say that should be anyway up to
the extension maintainers (ie a binder requering _ like mysql). That's
why I rather prefer to set a recommandation (to be used by default) and
, only if _required_ for easyness/technical reasons, use the alternative
naming.
> Of course, it is always easier to simply dismiss arguments
> which don't support your point. The price? Your
> credibility.
.
pierre