Re: Improve DateTime Class
| From: | Sebastian Krebs | Date: | Mon, 10 Dec 2012 12:23:01 +0000 |
| Subject: | Re: Improve DateTime Class | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-64220@lists.php.net to get a copy of this message | ||
Hi,
are you mabe just looking for
$date->add(new DateInterval('P15D'));
?
2012/12/10 Christian Stoller <stoller@leonex.de>
> Hi internals,
>
> what do you think about improving the modification functionality of the
> DateTime class. I always get a cold shiver, when I write something like
> this:
> <?php
> $date = new DateTime()
> $date->modify(‘+15 day’);
>
> In my opinion it would be nicer if one could write:
> $date->modify(15, DateTime::INTERVAL_DAY); // for adding 15 days
> $date->modify(-15, DateTime::INTERVAL_DAY); // for subtracting 15 days
>
> Even better would be to have methods like addDays(), addMonths(), etc.
>
> This would make it cleaner and more readable. You do not have to do
> something like this:
>
> $date = new DateTime();
> $date->modify(getDaysToAddMethod() . " day"); // I am not sure if a '+'
> sign is needed if the value is positive
>
> And it is fully backward compatible.
>
> Best regards
> Christian
>
>
--
github.com/KingCrunch