Re: Re: [PROPOSAL]Add second to callback of preg_replace_callback

From: Date: Sat, 04 May 2013 14:33:31 +0000
Subject: Re: Re: [PROPOSAL]Add second to callback of preg_replace_callback
References: 1 2 3 4 5 6 7 8  Groups: php.internals 
Request: Send a blank email to internals+get-67302@lists.php.net to get a copy of this message
On 05/04/2013 08:28 AM, Laruence wrote: > and inefficent not always means performance only, in this case , you > need to define various functions for different regexs if you use loop style. > > and do you prefer array_walk or foreach when you try to iteraterly > process an array? I certainly prefer foreach over array_walk/array_map because I think the resulting code is easier to read. It also happens to be faster to use foreach in every case I have ever tested. -Rasmus

« previous php.internals (#67302) next »