Re: Refactored magic methods

From: Date: Fri, 02 Aug 2013 19:55:04 +0000
Subject: Re: Refactored magic methods
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-68362@lists.php.net to get a copy of this message
> > If you have ideas or things to say, I'm listening. > https://github.com/jpauli/php-src/compare/macroing Is there a reason you switched from names like __toString to __tostring (https://github.com/jpauli/php-src/compare/macroing#L2R12)? Visually the macros clean things up a lot and better convey the intent behind the if / else if chain. However, I don't really like having a macro that works off of an ELSE, it just feels wrong. I don't have a better suggestion though.

« previous php.internals (#68362) next »