Re: More powerful (and backward compatible) API of random number generator functions
| From: | Marc Bennewitz | Date: | Fri, 30 Aug 2013 19:43:09 +0000 |
| Subject: | Re: More powerful (and backward compatible) API of random number generator functions | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-68756@lists.php.net to get a copy of this message | ||
Am 29.08.2013 14:00, schrieb Ángel González:
> Marc Bennewitz wrote:
>> Idea for an RFC for a more powerful (and backward compatible) API of
>> random number generator functions.
>>
>> The following psaudocode is self explained (hopfully)
>>
>> const RAND_ALGO_LIBC
>> const RAND_ALGO_MERSENNE_TWISTER
>> const RAND_ALGO_OPENSSL
>> const RAND_ALGO_GMP
> (...)
>> What do you think?
>
> Why do you want them?
The constants exists to have a more readable (and standardizes) name of
algorithms and helps the developer which algorithms exists without
calling rand_algo_list().