Re: Flexible function naming
| From: | Rowan Collins | Date: | Tue, 17 Dec 2013 01:49:12 +0000 |
| Subject: | Re: Flexible function naming | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-70694@lists.php.net to get a copy of this message | ||
On 17/12/2013 01:24, Rasmus Lerdorf wrote:
This was circa late 1994 when PHP was a tool just for my own personal use and I wasn't too worried about not being able to remember the few function names.Absolutely, and to make sure it's clear, I meant absolutely no offence or criticism in mentioning it. If I ever invent a language that comes to be used by millions, then just maybe I'd have the right to criticise. :) I actually picked htmlspecialchars() as an example because I remembered you using it as one at a conference. I guess I could have pointed out that in its way there was a naming convention: pick names with different lengths where possible - but I didn't want to drift off-topic. My main point is that if we were to impose a new naming scheme on existing functions, adding or removing underscores would be just the tip of the iceberg. -- Rowan Collins [IMSoP]