Re: Re: [RFC] Introduce session.lock, session.lazy_write and session.lazy_destory

From: Date: Fri, 03 Jan 2014 02:23:04 +0000
Subject: Re: Re: [RFC] Introduce session.lock, session.lazy_write and session.lazy_destory
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-70978@lists.php.net to get a copy of this message
On 02/01/2014 20:46, Yasuo Ohgaki wrote:
I've added session_discard() to RFC that discards changes made to session data and close session. Since there is session_commit(), http://www.php.net/manual/en/function.session-commit.php session_abort() may be better name for it. Any comment?
Since session_commit() is an alias for session_write_close(), the new function should probably also have "close" in its name (although oddly we "start" a session, rather than "open" it). Both "discard" and "abort" also sound a bit like destroying the session itself to me, rather than just ignoring the current changes to it. Perhaps something like session_revert_close() - "revert" being a closely analagous action in version control systems. Regards, -- Rowan Collins [IMSoP]

« previous php.internals (#70978) next »