Re: [VOTE] Introduce session.lock, session.lazy_write and session.lazy_destory

From: Date: Mon, 20 Jan 2014 08:42:38 +0000
Subject: Re: [VOTE] Introduce session.lock, session.lazy_write and session.lazy_destory
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-71309@lists.php.net to get a copy of this message
Hi Bas, On Mon, Jan 20, 2014 at 5:27 PM, Bas van Beek <bas@tobin.nl> wrote: > I see only one very simple function potentially being helpful. A simple > session close without write maybe called session_close(). This would give > a performance bonus as it will not need to serialize the session data and > write it back to session storage. It also helps to programmer in cases > that he wants to guarantee that the session store is not changed by > script (similar to a transaction abort). > I have already added this as session_abort(). Since it's only in 5.6 and master branch, the name could be changed. However, session_abort() (or something like session_discard()) would be better name because the name implies it does not save data. If you come up with better name, please let me know. Regards, -- Yasuo Ohgaki yohgaki@ohgaki.net

« previous php.internals (#71309) next »