Re: some thoughts about php 6

From: Date: Thu, 30 Jan 2014 08:53:59 +0000
Subject: Re: some thoughts about php 6
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-71788@lists.php.net to get a copy of this message
Hi all, On Thu, Jan 30, 2014 at 4:16 PM, Martin Keckeis <martin.keckeis1@gmail.com>wrote: > + 1 changes > - consistent 64 bit support (hopefully already 5.6) > - constistent Multibyte support > - string/array/scalar OOP style (like suggested from Pierre in his first > post with BC compability) > - everything which improves performance > > -1 changes > - rename functions names > - reorder function parameters > - case sensitivity > The same for me except case sensitivity. Full case sensitivity would be good for performance and users should have consistent name even if they use case insensitive file system, etc. IMO. There are to many strtolower() calls and it impacts performance a lot... BTW, I'm against rename functions. I don't want to rename functions but add aliases. These are totally different. Aliases would good for scalar OO API. We are better to have intuitive names $str->something() and str_something($str) To have consistent parameter order, we may have new name for them for both OO and procedural API. Regards, -- Yasuo Ohgaki yohgaki@ohgaki.net

« previous php.internals (#71788) next »