Re: not_null function

From: Date: Sat, 05 Jul 2014 08:12:20 +0000
Subject: Re: not_null function
Groups: php.internals 
Request: Send a blank email to internals+get-75261@lists.php.net to get a copy of this message
> On July 5, 2014 at 9:05 AM Pierre Joye <pierre.php@gmail.com> wrote: > > > On Jul 5, 2014 9:43 AM, "Tjerk Meesters" <tjerk.me esters a gmail.com> > wrote: > > > > > Obviously spoke to soon ... what I've written there is basically an ugly > > !isset($var). > > > > Totally fail to see what is ugly with is set or the difference with > exists(). The latter, in the context of php (even more with phpng) makes > little sense. > > Besides that, I am not sure what is the goal of this thread. Adding aliases > to copy cat <some language>? Can we please stop this ridiculous bikeshedding? It is incredible this thread has gone on for so long. PHP has idiosyncracies, but frankly, the is_null function is hardly the worst of them and I see nothing useful resulting from this discussion. -- Andrea Faulds http://ajf.me/

« previous php.internals (#75261) next »