Re: Use of php_mt_rand() rather than php_rand()
| From: | Andrea Faulds | Date: | Wed, 16 Jul 2014 18:00:28 +0000 |
| Subject: | Re: Use of php_mt_rand() rather than php_rand() | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-75595@lists.php.net to get a copy of this message | ||
On 16 Jul 2014, at 18:56, Rowan Collins <rowan.collins@gmail.com> wrote:
> Do you propose making rand() a synonym for mt_rand()? If so, wouldn't it make sense for
> srand() to become a synonym for mt_srand()?
Whether that’s what Yasuo proposes or not, I’d like to see this. It’s rather silly that rand()
isn’t the proper one, and that mt_rand() is. We could always rename rand() to legacy_rand() or
something.
--
Andrea Faulds
http://ajf.me/