Re: Naming issues, solutions
| From: | Dmitry Stogov | Date: | Mon, 25 Aug 2014 07:22:57 +0000 |
| Subject: | Re: Naming issues, solutions | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-76853@lists.php.net to get a copy of this message | ||
Hi Pierre,
I'm glad, you agree to rename IS_INT back to IS_LONG.
zend_long and size_t usage looks fine.
I see no problems changing zend_string related API and related macros
introduced in NG. They are new for everyone.
I hope, the changes won't make API less clear or useful (so it would be
great to review them).
I don't see a big reason to rename "zend_uint" into "uint32_t", but
it's
just my own opinion. I would prefer keep it as is, or at worse case rename
into "zend_uint32" or "uint32". Anyway, I'll agree with majority.
How are we going to proceed?
Do you like voting in https://wiki.php.net/rfc/better_type_names_for_int64
or you may just revert part of the int64 patch related to IS_LONG -> IS_INT
renaming?
Who is going to implement the rest? When? Do we need RFC?
May be it should be a general RFC about internal PHP APIs cleanup?
I know, there are a lot of other inconsistencies...
Thanks. Dmitry.
On Sun, Aug 24, 2014 at 5:21 PM, Pierre Joye <pierre.php@gmail.com> wrote:
> On Sun, Aug 24, 2014 at 3:20 PM, Rouven Weßling <me@rouvenwessling.de>
> wrote:
> >
> >
> >> Am 24.08.2014 um 14:30 schrieb Pierre Joye <pierre.php@gmail.com>:
> >>
> >> zend_uint > int32_t
> >
> > Is that a typo? If it's not, why are you changing it to signed?
>
> typo. It should be:
>
> zend_uint > uint32_t
>
> Thanks :)
>
> > Best regards
> > Rouven
>
>
>
> --
> Pierre
>
> @pierrejoye | http://www.libgd.org
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>