Re: Re: Fast zend_parse_parameters API

From: Date: Thu, 04 Sep 2014 14:00:41 +0000
Subject: Re: Re: Fast zend_parse_parameters API
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-77057@lists.php.net to get a copy of this message
On Thu, Sep 4, 2014 at 3:56 PM, Dmitry Stogov <dmitry@zend.com> wrote: > I like the idea of having a single syntax for all cases, but I don't like > the syntax you propose. > In my opinion, it's syntactically inconsistent, less readable and more > error prone, than the old one (sscanf based) and the FAST_ZPP one that is > already in php-master. I do not like any of the new ones, FAST_ZPP included. I find them all error prones and not as KISS as what we have now. As I understand correctly the only reason we have this discussion is the performance impact of zpp with some functions, mainly ZEND_FUNCTIONs. What prevents us to make them operators? That may break things like call_user_func("strlen", $arg), array_map and the likes but there may have ways to limit the BC breaks here too. If it avoid an endless discussion about APIs, it is worse the effort to try it. Cheers, -- Pierre @pierrejoye | http://www.libgd.org

« previous php.internals (#77057) next »