Re: Improving error messages when using indirect references
| From: | Hartmut Holzgraefe | Date: | Fri, 13 Feb 2004 14:47:08 +0000 |
| Subject: | Re: Improving error messages when using indirect references | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-7805@lists.php.net to get a copy of this message | ||
Martin Jansen wrote:
Hey,i'd prefere to put the variable name in single quotes here as the name actually is '' (empty string) <?php $foo = ""; $$foo = "hallo"; echo ${""}; ?> -- Hartmut Holzgraefe <hartmut@php.net><?php error_reporting(E_ALL);echo $$foo; ?>results inNotice: Undefined variable: foo in /foo/bar.php on line 4Notice: Undefined variable: in /foo/bar.php on line 4Wouldn't it be more appropriate if the second notice was something like "Notice: Undefined variable: <unnamed> in /foo/bar.php on line 4"?