Re: test sapi/fpm/tests/015.phpt
| From: | Remi Collet | Date: | Mon, 01 Dec 2014 06:09:22 +0000 |
| Subject: | Re: test sapi/fpm/tests/015.phpt | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-79330@lists.php.net to get a copy of this message | ||
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Le 01/12/2014 04:37, Stanislav Malyshev a écrit :
> Hi Remi!
>
> I see that the test sapi/fpm/tests/015.phpt is randomly
> intermittently failing all the time in CI, making it harder to
> evaluate fixes. The cause of the failure is additional one or two
> messages like this:
>
> ERROR: unable to read what child say: Bad file descriptor (9)
>
> Could you (or somebody else who knows FPM better than me) look into
> it and make it work or XFAIL it or disable it if it's impossible?
015 is the only test which rely on "catch_workers_output = yes"
So this feature seems to have issues :(
I think we should be able to write directly in the master error_log
without having to go through via this master-child-pipe solution.
I already have a patch and run some tests on this.
I will look at this ASAP (probably using XFAIL for now).
Notice: I think some downstream use php_admin_value[error_log]
which create a "per-pool" file, but owned by the non privileged child
user (not perfect for security, as the dir must be widely open).
With default config... (no catch_workers_output and no
php_admin_value) child messages are simply lost in /dev/null :(
Remi.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
iEYEARECAAYFAlR8BhIACgkQYUppBSnxahgNVgCfciNCGIvbvLqU13vA39wm3FHl
SoAAniqUOWBNMavbltgh0E3vi0FuKAqb
=rU2D
-----END PGP SIGNATURE-----