Re: [RFC] Preserve Fractional Part in JSON encode

From: Date: Thu, 25 Dec 2014 23:01:02 +0000
Subject: Re: [RFC] Preserve Fractional Part in JSON encode
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-79949@lists.php.net to get a copy of this message
> On 25 Dec 2014, at 19:32, Juan Basso <jrbasso@gmail.com> wrote: > > The RFC can be found here: > https://wiki.php.net/rfc/json_preserve_fractional_part Hey Juan, A further thought: is “Preserve Fractional Part” the best name? Integral floats like float(12) don’t have any fractional part, and besides, the name doesn’t tell you what it does IMO. Perhaps something like JSON_FLOAT_ADD_POINT_ZERO? It’s more literal and, I think, more obvious. Thanks. -- Andrea Faulds http://ajf.me/

« previous php.internals (#79949) next »