Re: [RFC][DISCUSSION] ReflectionParameter::getClassName()
| From: | Dan Ackroyd | Date: | Sun, 01 Feb 2015 01:23:49 +0000 |
| Subject: | Re: [RFC][DISCUSSION] ReflectionParameter::getClassName() | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-81513@lists.php.net to get a copy of this message | ||
On 31 January 2015 at 17:31, Philip Sturgeon <pjsturgeon@gmail.com> wrote:
> On Sat, Jan 31, 2015 at 3:12 AM, Matteo Beccati <php@beccati.com> wrote:
>>
>> 2) There's a tiny bit of overlap with "scalar type hints",
>
> 2) There might be some overlap in the scalar type hint stuff kinda,
> but I'd like to think there isn't. getClassName() is just
> getClass()->name
I think Matteo's point is that if any scalar type RFC passes, a
type-hint for a parameter would not always be the name of a class, so
the method name 'getClassName()' would be misleading.
It would be good to choose a better name to avoid that problem.
cheers
Dan