Re: "strict_types" should be renamed "raise_type_error". WAS: About declare(strict_types = 1)
| From: | Patrick ALLAERT | Date: | Wed, 18 Mar 2015 11:42:44 +0000 |
| Subject: | Re: "strict_types" should be renamed "raise_type_error". WAS: About declare(strict_types = 1) | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-85183@lists.php.net to get a copy of this message | ||
Le lun. 16 mars 2015 à 21:34, Matthew Leverton <leverton@gmail.com> a
écrit :
> (Although the irony of using =1 instead of =true isn't lost on me!)
>
Yes, I mentioned[1] that funny aspect earlier.
0 or 1 is explicitly required in order to update the boolean behind it
while true/false generates a fatal error with "strict_types declaration
must have 0 or 1 as its value".
[1] https://twitter.com/patrick_allaert/status/568167144363560961