Re: RFC: spl_autoload_register() should provide kind of entity to load

From: Date: Sun, 19 Apr 2015 13:36:04 +0000
Subject: Re: RFC: spl_autoload_register() should provide kind of entity to load
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-85869@lists.php.net to get a copy of this message
Yes, i finally rewritten major part of my code following the recommended SF2 standard for naming convention of trait/interfaces. Thanks Internals. Regards, Geo. Geolim4 2015-04-19 15:33 GMT+02:00 François Laupretre <francois@php.net>: > > De : georges [mailto:geolim4@gmail.com] > > > > Currently spl_autoload_register() pass the name of the class entity to > the > > first *Callable* argument​, but there is now way (as i far i know) to > know > > what kind of entity we're looking for. > > -Class ? > > -Interface ? > > -Trait? > > As others already said, classes, interfaces, and trait names share the > same table, and there are a lot of places where you cannot determine the > type you're looking for when autoloading a symbol. > > However, we'll need to provide a type when we extend autoloading to > functions and constants, if we do it someday. > > Regards > > François > > > >

« previous php.internals (#85869) next »