Re: PHP 7.1 - should we add a random_str() function?

From: Date: Sun, 04 Oct 2015 10:29:05 +0000
Subject: Re: PHP 7.1 - should we add a random_str() function?
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-88660@lists.php.net to get a copy of this message
Hey Scott, Scott Arciszewski wrote:
This is probably answerable by a quick yes/no and shouldn't need a ton of bikeshedding, but if that happens anyway I apologize in advance. I think random_bytes() and random_int() are great; they provide a much-needed building block in PHP 7.0. However, I do worry a bit that the most common use for random_int() (generating a random string of a fixed length with a given character set) will be reinvented over and over again, and rarely consistently. I would propose a random_str() function that behaves similar to this userland snippet: http://stackoverflow.com/a/32870871/2224584
Generating random strings of characters is difficult, yeah, so this seems useful. But I do wonder if this function is the right approach. What if you have some other source of bytes and want to also produce a sequence of characters matching some format? What I think might be better is some bytes-to-arbitrary base conversion function, one which lets you specify the character set to use. Then you could use that with random_bytes(), but also with something else, perhaps a public key? This way we don't have to duplicate the same functionality somewhere else. Thanks! -- Andrea Faulds http://ajf.me/

« previous php.internals (#88660) next »