Re: Re: [RFC Proposal] Null Coalesce Equal Operator

From: Date: Thu, 24 Mar 2016 20:35:27 +0000
Subject: Re: Re: [RFC Proposal] Null Coalesce Equal Operator
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-91927@lists.php.net to get a copy of this message
Hi, Sara Golemon wrote:
Changing "equal" to "assignment" seems to have been the suggestion. I've taken that into the short-ternary version. And as a minor edit (not worth closing/reopening vote) would recommend the same for null coallesce. -Sara
The other suggestion was to change "coalesce" to "coalescing", because the former is a grammatical error I made when I wrote the original ?? RFC, whereas the latter is the correct name. Actually, if we go back to my original email on this subject:
Den 2016-03-13 kl. 02:59, skrev Andrea Faulds:
I do have one thing to add, though. It's something of a nitpick, but the name ought to be the "null-coalescing assignment operator". This would follow the convention of referring to +=, -= etc. as compound/combined assignment operators[1][2], not "equal" operators (which sounds more like what == and === do, to me) and avoids the mistake ("coalesce" instead of "coalescing") that I originally made in my RFC for ??.[3] I think that RFC naming is important, because the name the author chooses for a feature tends to be the one that ends up in the manual.
I already gave a suggestion for a name there: "null-coalescing assignment operator". It's not a big deal, though. :) -- Andrea Faulds https://ajf.me/

« previous php.internals (#91927) next »