Re: Re: Improving PHP's type system

From: Date: Wed, 13 Apr 2016 19:57:41 +0000
Subject: Re: Re: Improving PHP's type system
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-92261@lists.php.net to get a copy of this message
On Wed, Apr 13, 2016 at 1:10 PM, Fleshgrinder <php@fleshgrinder.com> wrote: > Nothing to add other than +1, however, didn't you already write those? > > https://wiki.php.net/rfc/nullable_types > https://wiki.php.net/rfc/union_types > > Or is this just an announcement that these will be finalized now? > > Btw. I am in favor of having the question mark as a suffix and not as a > prefix because it is more readable and more natural to type. > > function fn(string? $str): bool?; > > Declare a function with the name fn that takes a string argument that is > nullable which will return a bool or null. > > That is exactly how I would think about the above while writing and > reading. :) > > -- > Richard "Fleshgrinder" Fussenegger > I have written them but later they will be formally moved to Under Discussion and will create new threads for them here on the mailing list.

« previous php.internals (#92261) next »