Re: [RFC] Libsodium - Discussion
| From: | Fleshgrinder | Date: | Sun, 05 Jun 2016 07:28:51 +0000 |
| Subject: | Re: [RFC] Libsodium - Discussion | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-93798@lists.php.net to get a copy of this message | ||
On 6/5/2016 12:25 AM, Stanislav Malyshev wrote:
> We don't really need the uniform part if we don't have the non-uniform
> one. If the only one we get is uniform, and it's the one we actually
> want, we should not spell it out in the name - we should name it
> something like random_int or random_range or random_between and explain
> in the docs that yes, it's the uniform one and it's the only you get
> because uniform is awesome.
>
https://secure.php.net/function.random-int
Is it uniform? That shouldn't be too hard to find out and the result
might be again that we actually don't need this new function at all.
--
Richard "Fleshgrinder" Fussenegger
Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc
Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc