Re: Adding validate_var_array()/validate_input_array() to which version?
| From: | Yasuo Ohgaki | Date: | Fri, 05 Aug 2016 00:15:39 +0000 |
| Subject: | Re: Adding validate_var_array()/validate_input_array() to which version? | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-94848@lists.php.net to get a copy of this message | ||
Hi all,
Pierre suggested the functions should be named "filter_*" and I agree.
On Fri, Aug 5, 2016 at 6:25 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote:
> Input validation is like assertion shouldn't fail.
How about
filter_assert_var() <- validate_var()
filter_assert_var_array() <- validate_var_array()
filter_assert_input() <- validate_input()
filter_assert_input_array() <- validate_input_array()
It seems better than
filter_validate_*()
to me. These names encourage users to use them for input assertion(validation).
Any other good names?
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net