Re: [RFC][DISCUSSION] Argon2 Password Hash
| From: | Niklas Keller | Date: | Fri, 05 Aug 2016 16:29:20 +0000 |
| Subject: | Re: [RFC][DISCUSSION] Argon2 Password Hash | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-94863@lists.php.net to get a copy of this message | ||
2016-08-05 14:47 GMT+02:00 Charles R. Portwood II <
charlesportwoodii@erianna.com>:
> Hello Internals,
>
> Due to a couple issue with the original RFC's scope, the RFC for
> introducing Argon2 as an alternative hashing algorithm for the password_*
> functions was closed shortly after starting on Monday.
>
> The following details were adjusted. and I would appreciate your feedback
> before re-opening the vote.
>
> - The RFC scope was reduced to only cover inclusion in 7.2. This RFC no
> longer proposes changes to PASSWORD_DEFAULT in 7.4.
> - Argon2d is not suitable for password hashing, and has been removed to
> keep in line with the scope goals of the password_* functions.
> - The configure flag was changed to --with-argon2 to
> --with-password-argon2 to further clarify the scope of this RFC.
>
> Further rationale for these items is provided in the RFC itself.
>
> The RFC is available at:
> https://wiki.php.net/rfc/argon2_password_hash.
>
> Thanks to those who emailed me directly to discuss the matter on Monday,
> and for your feedback on these changes.
>
> *Charles R. Portwood II*
>
Hi Charles,
I'd prefer
memory_cost and time_cost over m_cost and
t_cost. Do we
have any reason to use the shorter but less readable names here?
Regards, Niklas