Oops I forgot to post the error message
| From: | Taylor, Phillip | Date: | Thu, 20 Jun 2002 15:29:53 +0000 |
| Subject: | Oops I forgot to post the error message | ||
| Groups: | php.mirrors | ||
| Request: | Send a blank email to php-mirrors+get-10957@lists.php.net to get a copy of this message | ||
This is the error I am getting.
ptay1-ds# /www/bin/apachectl start
Syntax error on line 205 of /www/conf/httpd.conf:
Cannot load /www/libexec/libphp4.so into server: /www/libexec/libphp4.so:
Undefined symbol "core_globals"
/www/bin/apachectl start: httpd could not be started
ptay1-ds#
This is how I installed apache and php and the files that I included in the
httpd.conf file
I followed all of these steps to install the current version of php on my
freebsd server 4.3 and apache 1.3.26.
1. gunzip apache_xxx.tar.gz
2. tar -xvf apache_xxx.tar
3. gunzip php-xxx.tar.gz
4. tar -xvf php-xxx.tar
5. cd apache_xxx
6. ./configure --prefix=/www --enable-module=so
7. make
8. make install
9. cd ../php-xxx
10. ./configure --with-mysql --with-apxs=/www/bin/apxs
11. make
12. make install
If you decide to change your configure options after installation
you only need to repeat the last three steps. You only need to
restart apache for the new module to take effect. A recompile of
Apache is not needed.
11. cp php.ini-dist /usr/local/lib/php.ini
You can edit your .ini file to set PHP options. If
you prefer this file in another location, use
--with-config-file-path=/path in step 8.
12. Edit your httpd.conf or srm.conf file and check that these lines are
present and not commented out:
AddType application/x-httpd-php .php
LoadModule php4_module libexec/libphp4.so
You can choose any extension you wish here. .php is simply the one
we suggest. You can even include .html, and .php3 can be added for
backwards compatibility.
The path on the right hand side of the LoadModule statement must point
to the path of the PHP module on your system. The above statement is
correct for the steps shown above.
13. Use your normal procedure for starting the Apache server. (You must
stop and restart the server, not just cause the server to reload by
use a HUP or USR1 signal.)
Apache is installed in the /www and I added all the lines as it said in the
docs to the httpd.conf file. Why am I getting this error when I try and
start up appache?
/www/bin/apachectl start
These two lines are in my httpd.conf file
LoadModule php4_module libexec/libphp4.so
AddType application/x-httpd-php .php