#28666 [Com]: 500 Internal server error (on more than one mirror)
| From: | mark at campbellsclan dot com | Date: | Tue, 01 Feb 2005 02:35:06 +0000 |
| Subject: | #28666 [Com]: 500 Internal server error (on more than one mirror) | ||
| References: | 1 | Groups: | php.mirrors |
| Request: | Send a blank email to php-mirrors+get-27398@lists.php.net to get a copy of this message | ||
ID: 28666
Comment by: mark at campbellsclan dot com
Reported By: php dot mirror at camelnetwork dot com
Status: Open
Bug Type: Website problem
Operating System: N/A
PHP Version: Irrelevant
New Comment:
This problem is caused by this line in httpd.conf
AddHandler type-map var
This match is too loose and matches php doc ref.var.html when it seems
to be intended to match only docs ending in .var
I altered the line to
AddHandler type-map !.var
Which forces the comparison to the EOL and it solved the problem.
Previous Comments:
------------------------------------------------------------------------
[2004-06-09 17:43:06] toni dot viemero at iki dot fi
This bug is related to the one I reported in #28272
------------------------------------------------------------------------
[2004-06-09 15:27:05] goba@php.net
Seems like you have some module, which tries to find a matching mime
type for '.var' and the first bytes of the file, but is unable to. I am
not sure in this though. Some other mirrors had /manual/en/faq.html.php
returned as HTML for a similar reason.
In case you find out how to fix this, we would be more than happy to
include notes in the mirroring instructions to prevent this error in
the future.
------------------------------------------------------------------------
[2004-06-07 08:37:37] php dot mirror at camelnetwork dot com
Description:
------------
We had a user send an email informing us that the page:
http://uk2.php.net/manual/en/ref.var.php
Returns an "500 Internal Server Error"
I have tried removing the file and re-syncing with little success.
In the error log we have:
[Mon Jun 07 06:23:44 2004] [error] [client 213.230.200.234] Syntax
error in type map, no ':' in
/var/www/localhost/htdocs/manual/en/ref.var.php for header <?php \n
Expected result:
----------------
http://uk2.php.net/manual/en/ref.var.php To
produce std webpage.
Actual result:
--------------
On some mirrors it produces an "500 Internal Server" error.
I've checked some other mirrors (from kr.php.net down) and the ones
that produce error pages are:
"kr,kr2,lt,lt2,lu,ru3,sg,sg2,sk,uk,uk2,za,za2"
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=28666&edit=1