Re: pt.php.net mirror site deactivated
| From: | Gabor Hojtsy | Date: | Sat, 08 Jul 2006 20:49:00 +0000 |
| Subject: | Re: pt.php.net mirror site deactivated | ||
| References: | 1 2 3 4 5 6 | Groups: | php.mirrors |
| Request: | Send a blank email to php-mirrors+get-31953@lists.php.net to get a copy of this message | ||
Hi,
Nuno, I have just checked an hour ago if your mirror is correctly up in the list, or we need some more code modifications. I also dropped some long defunct mirrors from the list. Your mirror seems to be listed on several mirror sites (eg. gr.php.net, hu.php.net etc) but not on the main site. This should be due to www.php.net not being up to date enough. I don't know how often does the cron runs on www.php.net, but new data should be there soon.
Gabor
On Sat, 8 Jul 2006, Nuno Vieira - nfsi telecom wrote:
Howdy, Sorry for beign such a P.I.T.A. We are not yet relisted again on Mirrors List. Is there something that i need to do from our side ? The mirror is properly working here. (or at least it seems to be). Please give some feedback. On Jul 4, 2006, at 3:28 PM, Gabor Hojtsy wrote:OK, I picked up the issue from here. The problem is that our website code was written with the concept in mind that sys_getloadavg() is only available on www.php.net, so it redirects to a closer mirror on sites having sys_getloadavg() == running PHP 5.1 or later. I will fix the code tomorrow, unless someone beats me to it (I cannot do it now). Gabor On Tue, 4 Jul 2006, Nuno Vieira - nfsi telecom wrote:-- Nuno Vieira nfsi telecom, lda. Phone : +351 21 120 7200 Helpdesk: 707 780717Hello Gabor, Thanks for your info. I cannot replicate that behaviour here: twistedmonkey:~ twistedmonkey$ telnet pt.php.net 80 Trying 81.92.192.2... Connected to php.nfsi.pt. Escape character is '^]'. GET /mirror-info HTTP/1.1 Host: pt.php.net HTTP/1.1 200 OK Date: Tue, 04 Jul 2006 14:13:27 GMT Server: Apache/2.0.54 (Debian GNU/Linux) PHP/5.1.4-Debian-0.1~sarge1 X-Powered-By: PHP/5.1.4-Debian-0.1~sarge1 Content-language: en Set-Cookie: COUNTRY=PRT%2C81.92.200.101; expires=Tue, 11-Jul-2006 14:13:27 GMT; path=/; domain=.php.net X-PHP-Load: 0.03, 0.01, 0 Status: 200 OK Transfer-Encoding: chunked Content-Type: text/plain;charset=ISO-8859-1 3d http://pt.php.net/|5.1.4-Debian-0.1~sarge1|1152008456|0|0|en| e manual-noalias 210 has this something to do with the PHP strings from Debian ? On Jul 4, 2006, at 2:20 PM, Gabor Hojtsy wrote:Well, Nuno: $ telnet pt.php.net 80 GET /mirror-info HTTP/1.1 Host: pt.php.net HTTP/1.1 302 Found Date: Tue, 04 Jul 2006 13:15:32 GMT Server: Apache/2.0.54 (Debian GNU/Linux) PHP/5.1.4-Debian-0.1~sarge1 X-Powered-By: PHP/5.1.4-Debian-0.1~sarge1 Content-language: en Set-Cookie: COUNTRY=HUN%2C62.112.223.170; expires=Tue, 11-Jul-2006 13:15:39 GMT; path=/; domain=.php.net X-PHP-Load: 0, 0, 0 Location: http://hu2.php.net/mirror-info Transfer-Encoding: chunked Content-Type: text/html; charset=utf-8 0 See the Location header. Try again this with the pt2 mirror for example: HTTP/1.1 200 OK Date: Tue, 04 Jul 2006 13:17:29 GMT Server: Apache/1.3.22 (Unix) DAV/1.0.3 Mya/1.2 PHP/4.4.0 Content-Location: mirror-info.php Vary: negotiate TCN: choice X-Powered-By: PHP/4.4.0 Content-language: en Set-Cookie: COUNTRY=HUN%2C62.112.223.170; expires=Tue, 11 Jul 2006 13:17:34 GMT; path=/ Transfer-Encoding: chunked Content-Type: text/plain;charset=ISO-8859-1 3d http://php.linux.pt/|4.4.0|1152015644|0|0|en|manual-noalias|0 0 We should get a 200 OK response with the details shown. We don't get it. We check for this, because pt.php.net/echo and the like should display the echo page directly without any Location inbetween. Again, try http://pt2.php.net/echo Gabor On Mon, 3 Jul 2006, Nuno Vieira - nfsi telecom wrote:-- Nuno Vieira nfsi telecom, lda. Phone : +351 21 120 7200 Helpdesk: 707 780717once again. the mirror is active. what should we do to fix this ? this is not our problem. the mirror is working as it ever were. hope to ear from you soon. On Jul 2, 2006, at 12:24 PM, php-mirrors@lists.php.net wrote:Hi! Our automatic mirror site check was unable to reach the PHP.net mirror site maintained by you for three or more days now, *or* have found a permanent fatal error in your mirror setup. Therefore our bot automatically disabled your listing as an official PHP.net mirror site. The last error message stored for your mirror is: unable to get data (probably timeout) Please correct the problem or reply to this mail with your questions, if you think that the problem is not on your side. Your mirror will be kept disabled until the error is fixed. Mail sent out by the PHP.net automatic mirror site monitoring system-- Nuno Vieira nfsi telecom, lda. Phone : +351 21 120 7200 Helpdesk: 707 780717