#39133 [Opn->Bgs]: In reference manual, ref.var.html chokes Apache-2

From: Date: Sun, 15 Oct 2006 03:36:42 +0000
Subject: #39133 [Opn->Bgs]: In reference manual, ref.var.html chokes Apache-2
References: 1  Groups: php.mirrors 
Request: Send a blank email to php-mirrors+get-33050@lists.php.net to get a copy of this message
ID: 39133 Updated by: dave@php.net Reported By: jimc at math dot ucla dot edu -Status: Open +Status: Bogus -Bug Type: Documentation problem +Bug Type: Website problem Operating System: Linux PHP Version: Irrelevant New Comment: This isn't a documentation problem, changed to PHP.net Website problem (ie. mirrors). In any case, this report is bogus, as we require our mirrors to follow the mirror guidelines (http://php.net/mirroring.php), which states: # Apache2 has 'AddHandler type-map var' enabled by default. # Remove the comment sign on the line below if you have it enabled. # RemoveHandler var So changing the URL layout is unnecessary. Previous Comments: ------------------------------------------------------------------------ [2006-10-12 04:59:53] jimc at math dot ucla dot edu Description: ------------ An Apache web server (apache2-2.2.0) is sending out the PHP reference manual. 99.9% of the files arrive undamaged. However, when I ask for CXXIV "Variable Functions" (file basename: ref.var.html), Apache reports a 500 error (internal failure) and logs this message: Syntax error in type map, no ':' in /home/httpd/htdocs/php-doc/ref.var.html for header <!doctype html public "-//w3c//dtd html 4.01 transitional//en">\n, referer: http://localhost/php-doc/inde x.html I believe that ref.var is being interpreted (I think wrongly) as a type map file. Here's the section in the Apache manual: http://httpd.apache.org/docs/2.2/content-negotiation.html Here's a year-old bug report on the issue: http://mail-archives.apache.org/mod_mbox/httpd-bugs/200503.mbox/%3C200503022144.j22LiDJN002912@ajax.apache.org%3E (bug 33818, in case the URL can't be followed.) Although this is probably incorrect behaviour by Apache, you could get your documentation past it by changing the filename (and hrefs to it) so it doesn't look like it has an extension of ".var". This works for me as well as for the person who reported Apache bug 33818. I notice (using the Hurricane Electric mirror) that the online docs version, with the same basename, is served by that web server. I couldn't tell what kind of server it is. In Apache it's possible to turn off mod_negotiation or to change the filename extension for a type map. Expected result: ---------------- ref.var.html should have been displayed, same as ref.array.html and all the other sub-index pages. Actual result: -------------- Apache got error 500 and logged "syntax error in type map". This server *would* properly have considered ref.var to be a type map. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=39133&edit=1

« previous php.mirrors (#33050) next »