note 63691 added to security.cgi-bin.force-redirect

From: Date: Tue, 28 Mar 2006 13:25:25 +0000
Subject: note 63691 added to security.cgi-bin.force-redirect
Groups: php.notes 
Request: Send a blank email to php-notes+get-106848@lists.php.net to get a copy of this message
<p>This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.</p> <p>For more information as to <i>why</i> this behaviour exists, see the <a href="http://php.net/security.cgi-bin">manual page for CGI security</a>.</p> <p>For more information about changing this behaviour or re-enabling this webserver, consult the installation file that came with this distribution, or visit <a href="http://php.net/install.windows">the manual page</a>.</p> I been cracking my head over this issue until I realise that that cgi.force_redirect = 0 has been commented out in the php.ini file. Once it is uncommented, the above issue is solved. ---- Server IP: 203.202.10.60 Probable Submitter: 203.82.183.147 (proxied: 203.153.204.252) ---- X-Spam-Status: No, hits=3.1 required=5.0 tests=DATE_MISSING,FROM_NO_LOWER autolearn=no version=2.64 ---- Manual Page -- http://www.php.net/manual/en/security.cgi-bin.force-redirect.php Edit -- http://master.php.net/note/edit/63691 Del: integrated -- http://master.php.net/note/delete/63691/integrated Del: useless -- http://master.php.net/note/delete/63691/useless Del: bad code -- http://master.php.net/note/delete/63691/bad+code Del: spam -- http://master.php.net/note/delete/63691/spam Del: non-english -- http://master.php.net/note/delete/63691/non-english Del: in docs -- http://master.php.net/note/delete/63691/in+docs Del: other reasons-- http://master.php.net/note/delete/63691 Reject -- http://master.php.net/note/reject/63691 Search -- http://master.php.net/manage/user-notes.php

« previous php.notes (#106848) next »