note 67262 modified in function.setcookie by theseer
| From: | theseer@php.net | Date: | Fri, 07 Jul 2006 12:25:20 +0000 |
| Subject: | note 67262 modified in function.setcookie by theseer | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-114538@lists.php.net to get a copy of this message | ||
I just discovered that IE6 (6.0.2800.1106 at least) seems to have difficulties accepting cookies
when the subdomain part of the URL is longer than 10 characters. This applies to automatic
sessionid's as well (that's how I found out). So: Setting a cookie on a site named http://examples.test.com/ will work, doing the same on http://my_examples.test.com will fail (or at least, failed
for me).
Tested it by snooping the outgoing traffic from the client: the GET request lacks the COOKIE: header
in the last case. A closer inspection revealed that the cookie was never accepted in the first
place: when the subdomain is longer than 10 characters, no cookiefile is created in the temporary
internet files directory. Temporary cookies (like the PHP sessionid) have the same problem.
Firefox and Konqueror have no problem with this.
[Editor's note: Your comment is wrong. It is not the length of the hostname but the use of the
underscore (_) char within it which makes IE (silently) freak out. The use of underscores in
hostnames is an RFC violation and may very well not be supported at all by a browser, proxy or any
http client.]
--was--
I just discovered that IE6 (6.0.2800.1106 at least) seems to have difficulties accepting cookies
when the subdomain part of the URL is longer than 10 characters. This applies to automatic
sessionid's as well (that's how I found out). So: Setting a cookie on a site named http://examples.test.com/ will work, doing the same on http://my_examples.test.com will fail (or at least, failed
for me).
Tested it by snooping the outgoing traffic from the client: the GET request lacks the COOKIE: header
in the last case. A closer inspection revealed that the cookie was never accepted in the first
place: when the subdomain is longer than 10 characters, no cookiefile is created in the temporary
internet files directory. Temporary cookies (like the PHP sessionid) have the same problem.
Firefox and Konqueror have no problem with this.
http://php.net/manual/en/function.setcookie.php